乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

 [性价比之最]外挂制作从0开始到精通
教程
教程
培训
培训
产品
产品
客服
客服
易歪歪客服聊天助手——永久免费阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费最高2000云产品通用代金券我要租广告
查看: 1186|回复: 1
收起左侧

[求助] 【易语言多线程源码问题】超级列表框序号出现错乱和插入出现空白

[复制链接]
  • TA的每日心情

    2019-5-18 19:36
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    发表于 2019-4-17 20:34:57 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
                             QQ截图1.png
    如上图,超级列表框序号出现错乱和插入出现空白。求大佬们帮解决!
    引用了鱼翅多线程
    [ecode=0].版本 2
    .支持库 spec
    .支持库 iext

    .程序集 窗口程序集_启动窗口
    .程序集变量 集_句柄, 整数型
    .程序集变量 线程, 鱼刺类_线程操作
    .程序集变量 多线程, 鱼刺类_线程池Ex
    .程序集变量 许可证, 鱼刺类_临界许可

    .子程序 _按钮1_被单击

    .如果真 (线程.创建 (&分配线程, , 集_句柄, ) = 真)

        调试输出 (真)
        返回 ()

    .如果真结束
    调试输出 (假)

    .子程序 分配线程
    .局部变量 总任务, 整数型
    .局部变量 线程数量, 整数型
    .局部变量 执行线程数, 整数型
    .局部变量 N, 整数型

    总任务 = 到整数 (编辑框2.内容)
    线程数量 = 到整数 (编辑框1.内容)
    .如果真 (多线程.创建 (线程数量, 线程数量, ) = 假)
        调试输出 (假)
        返回 ()

    .如果真结束
    调试输出 (真)
    .计次循环首 (总任务, N)
        多线程.投递任务 (&主线程, N, )
        处理事件 ()
    .计次循环尾 ()

    .子程序 主线程
    .参数 线程数, 整数型
    .局部变量 账号, 文本型
    .局部变量 密码, 文本型
    .局部变量 表项, 整数型
    .局部变量 N, 整数型

    置随机数种子 ()
    许可证.进入 ()
    表项 = 超级列表框1.插入表项 (, 到文本 (线程数), , , , )
    账号 = 文本_取随机字母 (5, 0) + 文本_取随机数字 (3)
    超级列表框1.置标题 (表项 - 1, 1, 账号)
    许可证.退出 ()
    _延迟 (3000)
    密码 = 文本_取随机字母 (3, 0) + 文本_取随机数字 (5)
    许可证.进入 ()
    超级列表框1.置标题 (表项 - 1, 2, 密码)
    超级列表框1.置标题 (表项 - 1, 3, “正在zc,请稍等”)
    许可证.退出 ()
    _延迟 (3000)
    .计次循环首 (15, N)
        _延迟 (1000)
        许可证.进入 ()
        超级列表框1.置标题 (表项 - 1, 3, “[” + 到文本 (N) + “/15]”)
        许可证.退出 ()
        处理事件 ()
    .计次循环尾 ()
    .判断开始 (寻找文本 (账号, “1”, , 假) ≠ -1)
        许可证.进入 ()
        超级列表框1.置标题 (表项 - 1, 3, “zc成功”)
        许可证.退出 ()
        许可证.进入 ()
    .默认
        超级列表框1.置标题 (表项 - 1, 3, “zc失败”)
        许可证.退出 ()
    .判断结束


    .子程序 _按钮2_被单击

    线程_销毁 (集_句柄)
    多线程.销毁 ()
    多线程.rar (859.74 KB, 下载次数: 10)
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    4 天前
  • 签到天数: 587 天

    [LV.9]以坛为家II

    发表于 2019-4-18 00:08:23 | 显示全部楼层
    序号 建议用 程序集变量,毕竟多线程本来就不是按照顺序的~至于空白的话,自己在线程内判断一下
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 冀ICP备14018763号-1 )

    GMT+8, 2019-5-26 18:08 , Processed in 0.081299 second(s), 68 queries , Redis On.

    Powered by Discuz! X3.4

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表