易语言实地培训长期招生 QQ1615457736

乐易论坛

搜索
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
云课堂动态
查看: 1469|回复: 0
收起左侧

[易求助] 易语言播放器组件闪退

[复制链接]
  • TA的每日心情
    慵懒
    2020-5-18 09:17
  • 签到天数: 8 天

    [LV.3]偶尔看看II

    发表于 2020-5-14 10:26:53 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    制作视频播放器,我的视频组件打开MP4格式,wmv格式,avi格式的文件后,直接闪退
    WIN10 易语言5.8,易语言5.9,易语言5.7,都试过,不行,有大佬知道吗
    [AppleScript] 纯文本查看 复制代码
    .版本 2
    .支持库 wmp9
    .支持库 iext2
    
    .程序集 窗口程序集_启动窗口
    .程序集变量 目录, 文本型
    .程序集变量 文件夹, 整数型
    .程序集变量 视频文件, 文本型
    
    .子程序 _按钮1_被单击
    
    .如果真 (通用对话框1.打开 () = 真)
        目录 = 通用对话框1.文件名
        文件夹 = 倒找文本 (目录, “\”, , 假)
        目录 = 取文本左边 (目录, 文件夹)
        视频文件 = 寻找文件 (目录, )
        视频文件 = 寻找文件 (“*.mp4”, )
        .如果真 (视频文件 = “”)
            列表框1.加入项目 (视频文件, )
    
        .如果真结束
        .判断循环首 (视频文件 ≠ “”)
            视频文件 = 寻找文件 (, )
            .如果 (视频文件 = “”)
                跳出循环 ()
            .否则
                列表框1.加入项目 (视频文件, )
            .如果结束
    
        .判断循环尾 ()
        .如果真 (列表框1.现行选中项 = -1)
            列表框1.现行选中项 = 0
        .如果真结束
        播放器1.地址 = 目录 + 列表框1.取项目文本 (列表框1.现行选中项)
    
    .如果真结束
    
    
    .子程序 _列表框1_双击选择
    
    处理事件 ()
    播放器1.地址 = 目录 + 列表框1.取项目文本 (列表框1.现行选中项)
    
    
    .子程序 _分隔条1_被拖动
    .参数 原位置, 整数型
    .参数 目的位置, 整数型
    .局部变量 变动位置, 整数型
    
    变动位置 = 原位置 - 目的位置
    播放器1.宽度 = 播放器1.宽度 + 变动位置
    分隔条1.左边 = 分隔条1.左边 + 变动位置
    列表框1.宽度 = 列表框1.宽度 - 变动位置
    列表框1.左边 = 列表框1.左边 + 变动位置
    


    我知道答案 回答被采纳将会获得1 助乐 + 10 易币 已有0人回答

    读取文件之后直接闪退,也没有报错

    读取文件之后直接闪退,也没有报错

    用的这个组件

    用的这个组件
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    快速回复 返回顶部 返回列表