易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费程序员熬夜必备神器阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费全新E3,E5机器远程出租阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费阿里云虚拟机主机 低至350元/1年 最高2000云产品通用代金券我要租广告
TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能
WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
查看: 5430|回复: 5
收起左侧

[易求助] dz论坛post的问题

[复制链接]
  • TA的每日心情
    慵懒
    2018-7-1 12:18
  • 签到天数: 5 天

    [LV.2]偶尔看看I

    发表于 2017-8-10 21:44:29 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    我登录成功后点击转账 总是提示未登录 换了很多方法 换cookies 提示未登录要不就是提示“您当前的访问请求当中含有非法字符,已经被系统拒绝” 求大神帮忙!!!

    [ecode=2].版本 2
    .支持库 spec

    .程序集 窗口程序集_启动窗口
    .程序集变量 cookies, 文本型
    .程序集变量 idhash, 文本型
    .程序集变量 formhash, 文本型
    .程序集变量 _idhash, 文本型
    .程序集变量 转账登录_cookies, 文本型
    .程序集变量 欢迎_cookies, 文本型

    .子程序 getcode
    .局部变量 str, 文本型
    .局部变量 setcookies, 文本型
    .局部变量 update, 文本型

    str = 编码_Utf8到Ansi (网页_访问_对象 (“http://wuaiyiku.tk/lt/misc.php?m ... did=member::logging”, , , cookies, setcookies, , ))
    cookies = 网页_Cookie合并更新 (cookies, setcookies)

    _idhash = 文本_取出中间文本 (str, “updateseccode(\'”, “\'”)

    update = 文本_取出中间文本 (str, “&update=”, “&”)

    调试输出 (_idhash, update, setcookies)

    图片框1.图片 = 网页_访问_对象 (“http://wuaiyiku.tk/lt/misc.php?mod=seccode&update=” + update + “&idhash=” + _idhash, , , cookies, setcookies, )

    cookies = 网页_Cookie合并更新 (cookies, setcookies)


    .子程序 login
    .局部变量 str, 文本型
    .局部变量 t, 文本型

    str = 编码_Utf8到Ansi (网页_访问_对象 (“http://wuaiyiku.tk/lt/member.php ... =LyiNC&inajax=1”, 1, “formhash=” + formhash + “&referer=http%3A%2F%2Fwuaiyiku.tk%2Flt%2F.%2F&loginfield=username&username=” + 编码_URL编码 (编辑框_user.内容, 真, 真) + “&password=” + 编辑框_pass.内容 + “&questionid=0&answer=&seccodehash=” + _idhash + “&seccodemodid=member%3A%3Alogging&seccodeverify=” + 编辑框_code.内容, cookies, 转账登录_cookies, , , ))
    .判断开始 (寻找文本 (str, “欢迎您回来”, , 假) = -1)
        信息框 (“登录失败”, 0, , )
    .默认
        信息框 (“登录成功”, 0, , )
        ' 载入 (窗口1, , 假)
        输出调试文本 (“----------------------------------”)
        输出调试文本 (cookies)
        输出调试文本 (转账登录_cookies)
        输出调试文本 (“----------------------------------”)
        t = 转账登录_cookies
        输出调试文本 (编码_Utf8到Ansi (网页_访问_对象 (“http://wuaiyiku.tk/lt/”, , , , 欢迎_cookies)))


        ' 欢迎_cookies = 转账登录_cookies
        转账登录_cookies = “GEuf_2132_saltkey=” + 文本_取出中间文本 (cookies, “GEuf_2132_saltkey=”, “;”) + “;”
        转账登录_cookies = 转账登录_cookies + “GEuf_2132_auth=” + 文本_取出中间文本 (t, “GEuf_2132_auth=”, “;”) + “;”
        输出调试文本 (转账登录_cookies)
    .判断结束
    ' 调试输出 (str)


    .子程序 __启动窗口_创建完毕
    .局部变量 str, 文本型

    str = 编码_Utf8到Ansi (网页_访问_对象 (“http://wuaiyiku.tk/lt/member.php?mod=logging&action=login”, , , , cookies, ))
    ' 置剪辑板文本 (str)

    idhash = 文本_取出中间文本 (str, “updateseccode('”, “'”, , )
    formhash = 文本_取出中间文本 (str, “formhash” + #引号 + “ value=” + #引号, #引号, , )

    调试输出 (idhash, cookies, formhash)

    getcode ()


    .子程序 _图片框1_鼠标左键被按下, 逻辑型
    .参数 横向位置, 整数型
    .参数 纵向位置, 整数型
    .参数 功能键状态, 整数型

    getcode ()


    .子程序 _按钮_login_被单击

    login ()


    .子程序 _按钮1_被单击

    退出 ()


    .子程序 退出
    .局部变量 str, 文本型

    str = 编码_Utf8到Ansi (网页_访问_对象 (“http://wuaiyiku.tk/lt/member.php ... ogout&formhash=” + formhash, 1, “mod=logging&action=logout&formhash=” + formhash, cookies, , , ))
    ' 调试输出 (str)


    .子程序 _按钮2_被单击
    .局部变量 str, 文本型
    .局部变量 form, 文本型
    .局部变量 局_formhash, 文本型

    str = 编码_Utf8到Ansi (网页_访问 (“http://wuaiyiku.tk/lt/home.php?m ... dit&op=transfer”, , , 转账登录_cookies))
    ' 输出调试文本 (form)
    局_formhash = 文本_取出中间文本 (str, “formhash” + #引号 + “ value=” + #引号, #引号 + “ />”)
    输出调试文本 (局_formhash)
    str = 编码_Utf8到Ansi (网页_访问 (“http://wuaiyiku.tk/lt/home.php?m ... dit&op=transfer”, 1, “formhash=” + formhash + “&transfersubmit=true&handlekey=transfercredit&transferamount=” + 编辑框1.内容 + “&to=” + 编码_URL编码 (“admin”, 真) + “&password=” + 编辑框_pass.内容 + “&transfermessage=%E7%9C%8B%E4%BA%86xx%E8%A7%86%E9%A2%91&transfersubmit_btn=true”, 欢迎_cookies, , , ))
    输出调试文本 (str)
    .判断开始 (寻找文本 (str, “积分转帐成功”, , 假) ≠ -1)
        信息框 (“转帐成功!”, 0, , )
    .默认

    .判断结束

    [/ecode]

    dz论坛.zip

    178.06 KB, 下载次数: 3

    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    慵懒
    2018-7-1 12:18
  • 签到天数: 5 天

    [LV.2]偶尔看看I

     楼主| 发表于 2017-8-10 21:46:35 | 显示全部楼层
    有人不???
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情

    昨天 08:06
  • 签到天数: 874 天

    [LV.10]以坛为家III

    发表于 2017-8-10 22:08:55 | 显示全部楼层
    formhash 不对
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2018-7-1 12:18
  • 签到天数: 5 天

    [LV.2]偶尔看看I

     楼主| 发表于 2017-8-10 22:27:59 高端的乐易手机用户 | 显示全部楼层
    揰掵佲 发表于 2017-8-10 22:08
    formhash 不对

    formhash 不是这样取的么?
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2018-7-1 12:18
  • 签到天数: 5 天

    [LV.2]偶尔看看I

     楼主| 发表于 2017-8-10 22:30:46 高端的乐易手机用户 | 显示全部楼层
    揰掵佲 发表于 2017-8-10 22:08
    formhash 不对

    可以帮我修改下么?
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2018-7-1 12:18
  • 签到天数: 5 天

    [LV.2]偶尔看看I

     楼主| 发表于 2017-8-11 12:35:00 | 显示全部楼层
    没人了吗?
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-4-9 04:41 , Processed in 0.114731 second(s), 110 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表