易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
查看: 6380|回复: 3
收起左侧

[已解决] 大文本读取至列表框(超级列表框或虚表)

[复制链接]
  • TA的每日心情

    2020-5-26 15:31
  • 签到天数: 38 天

    [LV.5]常住居民I

    发表于 2017-10-30 15:48:36 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    本帖最后由 怀念一片叶子 于 2017-10-30 15:51 编辑

    源文本 无非就是 账号----密码  这样,百万的数据在100M以内,不存在变量放不下这么一说

    个人实现思路如下
    用快速文本 先将整行的内容加载至文本数组中,测试双核CPU 处理200万行的数据需要6分钟

    [ecode=1].版本 2
    .支持库 commobj
    .支持库 spec

    .子程序 子程序1
    .参数 文件, 文本型
    .局部变量 text, 快速文本对象
    .局部变量 sz, 文本型, , "0"
    .局部变量 sz_, 文本型, , "0"
    .局部变量 账号, 文本型, , "0"
    .局部变量 密码, 文本型, , "0"
    .局部变量 i, 整数型

    调试输出 (取现行时间 ())
    text.从文件读 (文件)
    sz = text.分割文本 (#换行符, )
    .counter (取数组成员数 (sz), i)
        sz_ = 分割文本 (sz , “----”, )
        加入成员 (账号, sz_ [1])
        加入成员 (密码, sz_ [2])
    .CounterLoop ()
    清除数组 (sz)
    清除数组 (sz_)
    调试输出 (取现行时间 ())[/ecode]




    用打开文件在3分钟左右

    [ecode=1].版本 2
    .支持库 spec

    .子程序 子程序1
    .参数 文件, 文本型
    .局部变量 文件号, 整数型
    .局部变量 sz, 文本型, , "0"
    .局部变量 账号, 文本型, , "0"
    .局部变量 密码, 文本型, , "0"
    .局部变量 i, 整数型

    调试输出 (取现行时间 ())
    文件号 = 打开文件 (文件, , )
    移到文件首 (文件号)
    .while (是否在文件尾 (文件号, 真) = 假)
        sz = 分割文本 (读入一行 (文件号), “----”, )
        加入成员 (账号, sz [1])
        加入成员 (密码, sz [2])
    .wend ()
    清除数组 (sz)
    调试输出 (取现行时间 ())
    [/ecode]




    光读取文件就已经用了3分钟,即使边读取边插入超级列表框都需要10分钟以上,
    有没有大佬有更好的实现思路给个例子。
    揰掵佲已获得悬赏 1 助乐

    最佳答案

    QQ已经告诉你了
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情

    昨天 00:14
  • 签到天数: 927 天

    [LV.10]以坛为家III

    发表于 2017-10-30 16:54:37 | 显示全部楼层
    这样很慢的。。。。你不如直接用代码编辑框

    点评

    虫大 能扔我个例子么  详情 回复 发表于 2017-10-30 19:31
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2020-5-26 15:31
  • 签到天数: 38 天

    [LV.5]常住居民I

     楼主| 发表于 2017-10-30 19:31:50 | 显示全部楼层
    揰掵佲 发表于 2017-10-30 16:54
    这样很慢的。。。。你不如直接用代码编辑框

    虫大  能扔我个例子么
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    昨天 00:14
  • 签到天数: 927 天

    [LV.10]以坛为家III

    发表于 2017-10-30 19:49:32 | 显示全部楼层
    怀念一片叶子 发表于 2017-10-30 19:31
    虫大  能扔我个例子么

    QQ已经告诉你了
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-6-3 02:28 , Processed in 0.070398 second(s), 102 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表