易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
查看: 9135|回复: 2
收起左侧

[易求助] java算法转到易语言

[复制链接]
  • TA的每日心情

    2020-5-5 20:56
  • 签到天数: 16 天

    [LV.4]偶尔看看III

    发表于 2018-4-3 07:47:52 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x

    arg7={ “0”, “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “A”, “B”, “C”, “D”, “E”, “F” }

    ------------------------------   
    protected static char[] a(byte[] arg6, char[] arg7) {
            int v0 = 0;
            int v2 = arg6.length;
            char[] v3 = new char[v2 << 1];
            int v1;
            for(v1 = 0; v1 < v2; ++v1) {
                int v4 = v0 + 1;
                v3[v0] = arg7[(arg6[v1] & 240) >>> 4];
                v0 = v4 + 1;
                v3[v4] = arg7[arg6[v1] & 15];
            }

            return v3;
        }
    }
    自己有尝试着弄出来都不是结果,求告知!!
    揰掵佲已获得悬赏 1 助乐+10 易币

    最佳答案

    可以改成JS的,其实,最好是带上传递的参数和结果,方便对比
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情

    昨天 00:14
  • 签到天数: 927 天

    [LV.10]以坛为家III

    发表于 2018-4-3 13:29:47 | 显示全部楼层

    回帖奖励 +2 易币

    可以改成JS的,其实,最好是带上传递的参数和结果,方便对比
    1. function LeyBc() {
    2.     arg6 =  [52, 57, 55, 52, 49, 52, 70, 67, 51, 54, 53, 56, 69, 57, 55, 49, 54, 50, 52, 69, 69, 52, 52, 48, 70, 69, 53, 48, 48, 68, 57, 52, 52, 57, 55, 52, 49, 52, 70, 67, 51, 54, 53, 56, 69, 57, 55, 49, 54, 50, 52, 69, 69, 52, 52, 48, 70, 69, 53, 48, 48, 68, 57, 52 ]
    3.     arg7 = ["0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "A", "B", "C", "D", "E", "F"];
    4.     var v0=0;
    5.     var v2 = arg6.length;
    6.     var v3 = new Array(v2<<1);
    7.     var v1=0;
    8.     for (v1 = 0; v1 < v2; ++v1) {
    9.         v4 = v0 + 1;
    10.         v3[v0] =arg7[(arg6[v1] & 240) >>> 4];
    11. //console.log(  v3[v0]);
    12.         v0 = v4 + 1;
    13.         v3[v4]=arg7[arg6[v1] & 15];

    14.     }

    15.     return v3+"";
    16. }
    复制代码


    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    郁闷
    2018-10-14 11:34
  • 签到天数: 46 天

    [LV.5]常住居民I

    发表于 2018-4-4 01:39:39 | 显示全部楼层
    本帖最后由 望英雄 于 2018-4-4 01:43 编辑

    [ecode=4].版本 2

    .子程序 乐易论坛, 字节集
    .参数 arg6, 字节集
    .参数 arg7, 字节集
    .局部变量 v1, 整数型
    .局部变量 v0, 整数型
    .局部变量 v2, 整数型
    .局部变量 v3, 字节集
    .局部变量 v4, 整数型
    .局部变量 v, 整数型

    v0 = 0
    v2 = 取字节集长度 (arg6)
    v3 = 取空白字节集 (左移 (v2, 1))
    v1 = 1
    .判断循环首 (v1 < v2)
        v4 = v0 + 1
        v = 位与 (arg6 [v1], 240)
        v3 [v0] = arg7 [右移 (v, 4)]
        v0 = v4 + 1
        v3 [v4] = arg7 [位与 (arg6 [v1], 15)]
        v1 = v1 + 1
    .判断循环尾 ()
    返回 (v3)
    [/ecode]

    循环+位于的操作,不知道改写是否正确,因为没有提供数据进行测试
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-6-3 01:53 , Processed in 0.048728 second(s), 98 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表