易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费最高2000云产品通用代金券我要租广告
查看: 4614|回复: 6
收起左侧

[原创开源] 【源码】OCR识别接口,源码例子,给个图片,返回内容

[复制链接]
  • TA的每日心情
    开心
    2019-8-22 05:41
  • 签到天数: 260 天

    [LV.8]以坛为家I

    发表于 2018-11-24 14:34:10 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    啥也不说,直接上源码,不加权限,多给回复,谢谢。, K+ i& B: p* d( G! q! o

    3 D( N) p4 W( H                               
    登录/注册后可看大图
    * c: i/ H6 H/ a1 q" y

    3 F2 f9 _3 g7 S4 Y
    % g: H$ o1 {  g8 M: o5 R, J+ M& R
    8 f+ L) S$ n7 x; b4 ^* Z2 j  _4 t
    ) v6 V% D# X/ i% k/ i5 b: r2 ~* G
                                   
    登录/注册后可看大图
    # V8 M9 ^( j  a$ o* Q( ?3 O, T
    + E9 u3 ?! B- c5 }# j

    3 e8 N: J, k( i0 h[ecode=4].版本 2" R& {+ x; Z7 x" u4 Q2 V
    .支持库 internet2 s6 P5 H6 _% e4 f  n6 f
    .支持库 spec
    & E. B% R% t# u/ u8 G$ y$ D4 T
    1 q( ?* D( b0 P2 i: a.程序集 窗口程序集_启动窗口
    3 ]/ \2 S" R2 x; z! t4 M) w8 y.程序集变量 img_data_u, 字节集& r- v+ [, ]7 |( _1 j4 L

    . x0 H4 f7 p, c- Z/ ^.子程序 __启动窗口_创建完毕
    ! i# l; E/ h5 \  P* T5 s  S  f$ B( c& t/ c, X  Y2 N+ L8 _
    img_data_u = HTTP读文件 (“http://p0.qhimgs4.com/t014b70aac7897c728b.jpg”)
    . n' ]# ^! L% K/ I8 P' e3 K3 @图片框1.图片 = img_data_u
    ! P7 O8 {# k2 m( Q" x0 u
    & w% I8 I- ~' q# e0 O" j, ~( x.子程序 OCR_PIC_TEXT, 文本型
    7 O6 s3 ?2 X( ]4 L.参数 img_data, 字节集
    * l& Q6 Z, Y& B4 h  O! ^; E/ l( p.参数 fram, 逻辑型, 可空, 图片坐标,默认为空,值为假不输出,为真时输出% _* S/ ~. ]3 I; z. S( r5 B+ Z
    .局部变量 url, 文本型
    8 t; Y2 K4 @% H.局部变量 data, 字节集8 A. Z6 ^0 u, D0 ~* r* Q) q7 t. `
    .局部变量 res, 文本型
    % w2 I- i9 J3 P2 \) Q* H.局部变量 num, 整数型
    " Q0 J& _( T4 `+ C  S.局部变量 Json, 类_json
    6 r4 g1 _+ P0 K2 N% ~( _0 A.局部变量 data1, 文本型
    ! X: z3 O" u1 \. r, V# S8 F9 q2 u.局部变量 data2, 文本型; p8 K% |+ w; v' e2 l& x9 F* E
    .局部变量 res_data, 文本型
    & o; X, g0 s3 h/ w9 @& X9 w0 O  v1 ~% S/ L0 l" b% Z+ f' |( R
    url = “http://ocr.shouji.sogou.com/v2/ocr/json8 l! C% f3 M% M
    data = 到字节集 (#post_DATA)6 D9 C7 b; o) M% ^
    data = 子字节集替换 (data, 到字节集 (“{IMG_DATA}”), img_data, , )
    " c3 ]9 ^, W' Z! sres = 到文本 (网页_访问 (url, 1, , , , #HEADER, , , data))
    0 d. t( p. d, ~6 M: d9 T1 Xres = 编码_utf8到gb2312 (res), [7 ~. Y& n& a5 O. D' M. {/ K! c
    .if (json.解析 (res))
    1 ]7 _8 m( S* Q    .counter (json.成员数 (“result”), num)# B( u2 a% d' I( Q8 y2 f$ J. A+ ^
            .ife (是否为空 (fram) 或 fram = 假)$ D+ X- z2 {4 p. z9 k# v0 n& m2 N
                data2 = “”/ c: L5 K$ W8 k2 b8 m, K3 O3 _* W0 @0 z+ T
            .否则
    ) ~: v) Q  m* e3 S) r( g  q            data2 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].frame”); F2 X  M- [$ I
            .如果结束* g% v3 j1 X4 @1 y6 O3 ]
            data1 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].content”)
      X% h* a) |9 Y* N5 n/ j- U% g3 Z        .ife (data2 = “”)
    % U: L. g; W+ p& p7 ^# L0 ]            res_data = res_data + data1 + #换行符5 ~- C! K* k# }! _0 b( j
            .否则
    + ]7 j  X2 R9 p$ S/ ]8 K$ G            res_data = res_data + data1 + #换行符 + data2 + #换行符5 T0 A& T- I8 f8 J5 j3 j
            .如果结束5 b% b  |0 m1 N( R

    " t% M5 n. c4 w) n    .CounterLoop ()% R  Q; O4 I' W/ R
    .如果真结束
    5 P2 s4 `) d* ?! Greturn (res_data)
    . M( L6 ^) t# Q9 o9 K* Z- Z
    7 x, y5 o; `+ A0 V
    0 ?% w+ E" {3 E5 D. w) N* H.子程序 _按钮1_被单击& I2 H" C5 W+ P$ i( g3 [

    6 [7 O/ T. [" w' t  r0 d- k& J调试输出 (OCR_PIC_TEXT (img_data_u))
      i; _4 C; K" u9 x9 k3 c3 |+ e1 i& q/ @. o

    9 K% V9 \3 |3 ~, E( a0 o! P.版本 2
    * h& z" q) c# C& i, f& j! `; i$ I8 l
    .常量 头, "<文本长度: 129>"
    % u; K& }6 M5 Q8 p0 Z  K.常量 常量2( e5 W6 X4 f* b2 U
    .常量 POST_DATA, "<文本长度: 209>"
    * |- v# m. I, y6 c& d8 H4 K.常量 前面, "<文本长度: 11>"
      T  i4 D! M) S& N* g.常量 后面, "<文本长度: 8>"
    6 ~( x4 Y, [# d8 W4 h, z.常量 HEADER, "<文本长度: 79>"& y6 z) C% e/ i( G# {, J6 p  N6 G
    ! T. f" K) c6 K) N
    , l& n. c5 M/ X" Z* O
    [/ecode]# |9 ?* L: R, g- L
    0 A  p4 ~2 [' f8 ^& [5 V
    QQ截图20181124143343.png
    t014b70aac7897c728b.jpg
    t014b70aac7897c728b.jpg

    OCR.e

    690.4 KB, 下载次数: 30, 下载积分: 易币 -1

    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    8 小时前
  • 签到天数: 694 天

    [LV.9]以坛为家II

    发表于 2018-11-24 15:42:38 | 显示全部楼层
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

  • TA的每日心情
    开心
    2019-8-22 05:41
  • 签到天数: 260 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-24 15:43:10 | 显示全部楼层

    ! A# W2 q5 O3 }& q- d
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-3-8 23:04
  • 签到天数: 12 天

    [LV.3]偶尔看看II

    发表于 2018-11-25 14:38:38 | 显示全部楼层
    用搜狗的接口都不用给钱了,哈哈
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2018-12-9 07:16
  • 签到天数: 10 天

    [LV.3]偶尔看看II

    发表于 2018-11-26 11:54:33 | 显示全部楼层
    验证码能识别?

    点评

    你可以试试。具体不晓得。  详情 回复 发表于 2018-11-26 11:55
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2019-8-22 05:41
  • 签到天数: 260 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-26 11:55:49 | 显示全部楼层
    1301ok 发表于 2018-11-26 11:54, Y3 M% y2 x$ I# K3 p1 x
    验证码能识别?

    ' x! f% ]3 P* U( {你可以试试。具体不晓得。
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2019-1-25 14:32:26 | 显示全部楼层
    小姐姐,好像要
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2019-9-17 10:32 , Processed in 0.102639 second(s), 72 queries , Redis On.

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表