易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
查看: 6537|回复: 7
收起左侧

[原创开源] 【源码】OCR识别接口,源码例子,给个图片,返回内容

[复制链接]
  • TA的每日心情

    2020-5-28 21:47
  • 签到天数: 288 天

    [LV.8]以坛为家I

    发表于 2018-11-24 14:34:10 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    啥也不说,直接上源码,不加权限,多给回复,谢谢。& m) |1 V, ]$ r

    $ {4 z8 ?' s5 t% j/ r
    : ]  _+ G. `0 N7 i0 ^. s' G" A  W( r6 Y! C. f( H- x% w+ ^

    & H4 ~8 |4 l! \8 K8 ?' s* z" `3 z5 M3 L. `- R, d

    % H& B$ P$ A: j5 u4 O8 g& u# E, S$ f! r3 U1 z
    [ecode=4].版本 2
    4 d, X8 {& _3 k2 f.支持库 internet6 P! B* U* W1 D& G+ S' q
    .支持库 spec9 v! W, t' G" m) j
    & ?! b1 W: X- L" j, E
    .程序集 窗口程序集_启动窗口
    ! ~0 K; u3 ]; ]/ X% F2 t8 _# L.程序集变量 img_data_u, 字节集& P/ c. _( r3 q% X( U1 s. v$ \

    # B" }: E5 v2 ~2 b.子程序 __启动窗口_创建完毕0 a1 o0 \4 O& v: y

    0 d" d2 q! b! n4 u+ B4 f' Uimg_data_u = HTTP读文件 (“http://p0.qhimgs4.com/t014b70aac7897c728b.jpg”)+ M  {$ r  U5 o  V" f' g
    图片框1.图片 = img_data_u; R( c0 t7 G- I
    / U3 O, W1 R, o0 u/ _
    .子程序 OCR_PIC_TEXT, 文本型
    * P" {. F" z' d$ }1 r.参数 img_data, 字节集
    6 b; V( f8 |1 T1 }7 G2 I.参数 fram, 逻辑型, 可空, 图片坐标,默认为空,值为假不输出,为真时输出) c5 \' U/ i. L! r/ J. G  }
    .局部变量 url, 文本型
    # B/ X+ |  C1 Z* o) i.局部变量 data, 字节集( \, Z/ P0 O. c1 k( ?$ d
    .局部变量 res, 文本型
    : }" @5 b$ u; C2 Z% [.局部变量 num, 整数型5 A0 y, k& X( ?2 s" r6 _, k
    .局部变量 Json, 类_json
    1 L" Q( x% D) j4 P/ O; s9 G.局部变量 data1, 文本型
    ( u. a# s  n, }7 z+ ].局部变量 data2, 文本型
    1 \/ H5 `, Q: g' [2 ^7 j% D+ z.局部变量 res_data, 文本型
    0 v) f% u8 t! Q; Z- l- }8 d& y+ y5 I1 H" i$ [/ c8 L7 a9 o3 Y
    url = “http://ocr.shouji.sogou.com/v2/ocr/json! c5 P- X4 o" _9 y" t, u6 G9 h* ?
    data = 到字节集 (#post_DATA). ^, @! [6 f/ k% e$ D3 Q! ^
    data = 子字节集替换 (data, 到字节集 (“{IMG_DATA}”), img_data, , )
    # J6 e, u3 W% a4 P/ Cres = 到文本 (网页_访问 (url, 1, , , , #HEADER, , , data)): I; |: r2 X9 [4 T" R6 J, w. H
    res = 编码_utf8到gb2312 (res)( v' w; m% p3 A) G  v* u% J
    .if (json.解析 (res))
    $ b, m' p( G6 f9 R  Z0 A% u    .counter (json.成员数 (“result”), num)
    " n; T9 _# _; o. [, `, m        .ife (是否为空 (fram) 或 fram = 假)
      X  W) Y+ r4 K" f4 x3 X6 J8 R            data2 = “”1 Z% Z! T* u0 _  K$ y+ u
            .否则
    ' h, v+ W( Q8 k  h  {7 Y! y; d$ Y            data2 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].frame”)
    # I, p. U! ]' g2 x+ X( S+ _& z( {, L        .如果结束& \! |% ?: }4 x
            data1 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].content”)
    1 E/ t; u9 L) I* ?6 o        .ife (data2 = “”)
    8 J0 X' {8 y/ ?; f- X2 p: e. }            res_data = res_data + data1 + #换行符
    ! _& F7 ]) X: Z' d3 h3 W/ t        .否则# Q. @/ e2 V6 X; ]4 m( z
                res_data = res_data + data1 + #换行符 + data2 + #换行符
    1 _% m' {. e' |  y5 k2 w6 S3 Z        .如果结束6 X$ m6 j* D1 V; j: M5 a& G! \

    * F; p' m4 I' _' f    .CounterLoop ()+ E/ S' p, }( ?$ ^
    .如果真结束
    1 D4 G  F) j! r' c5 ]  _4 v0 l2 Nreturn (res_data)
    + c# f. N* ?* p) o6 P+ k1 |0 N1 h+ Z1 ?- ~. ?1 L- f
    ! m  D3 ^4 ?* R+ I
    .子程序 _按钮1_被单击) g. _3 R8 u# H! U* }+ J5 Z9 R7 b6 |, F8 d
    3 K& e: f9 |, s
    调试输出 (OCR_PIC_TEXT (img_data_u))" a; S1 e7 Y: @; k% m, h

    + O5 z- @$ r- S+ w; g) i! ?, B& F& w0 w) L6 n
    .版本 2) n+ t9 r1 O. @% M+ ~4 }

      C5 i6 i  _! L.常量 头, "<文本长度: 129>"4 o7 e& f. `% L& K' O
    .常量 常量20 B4 Z$ ^3 Z) K, V, D
    .常量 POST_DATA, "<文本长度: 209>"
    / S, ]! h7 M! A. D( r5 T.常量 前面, "<文本长度: 11>"
    0 N1 a* e; |; n7 ?5 B, _" K# U.常量 后面, "<文本长度: 8>"" m( a) z- @8 F, y( p9 Z
    .常量 HEADER, "<文本长度: 79>"
    5 s7 V; ]/ Y6 j+ v( J( M- d5 }# r/ B# l
    & d+ m/ R+ @# H! D7 `% u9 q5 I# B: P% b# g1 B
    [/ecode]6 H: _' Z8 G# m) i; L. q+ [# u. H

    $ u, j1 c' g/ g% O, `" }* W
    QQ截图20181124143343.png
    t014b70aac7897c728b.jpg
    t014b70aac7897c728b.jpg

    OCR.e

    690.4 KB, 下载次数: 46, 下载积分: 易币 -1

    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    郁闷
    4 小时前
  • 签到天数: 931 天

    [LV.10]以坛为家III

    发表于 2018-11-24 15:42:38 | 显示全部楼层
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情

    2020-5-28 21:47
  • 签到天数: 288 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-24 15:43:10 | 显示全部楼层
    * Z% z/ U* \. E" }/ a1 Q
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2020-5-7 11:18
  • 签到天数: 16 天

    [LV.4]偶尔看看III

    发表于 2018-11-25 14:38:38 | 显示全部楼层
    用搜狗的接口都不用给钱了,哈哈
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2018-12-9 07:16
  • 签到天数: 10 天

    [LV.3]偶尔看看II

    发表于 2018-11-26 11:54:33 | 显示全部楼层
    验证码能识别?

    点评

    你可以试试。具体不晓得。  详情 回复 发表于 2018-11-26 11:55
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2020-5-28 21:47
  • 签到天数: 288 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-26 11:55:49 | 显示全部楼层
    1301ok 发表于 2018-11-26 11:545 H) E8 P3 |9 }
    验证码能识别?

    7 K# X( \  K3 p* X/ c你可以试试。具体不晓得。
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2019-1-25 14:32:26 | 显示全部楼层
    小姐姐,好像要
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    擦汗
    2020-5-27 10:20
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2020-5-27 10:31:00 | 显示全部楼层
    验证码可以识别吗,有人验证过吗
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-6-6 06:12 , Processed in 0.062219 second(s), 112 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表