易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费
验证码识别/打码平台/谷歌人机验证/
阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费各类验证码定制,注册赠送¥588礼包,点击领取阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费接码打码最高2000云产品通用代金券我要租广告
查看: 5497|回复: 6
收起左侧

[原创开源] 【源码】OCR识别接口,源码例子,给个图片,返回内容

[复制链接]
  • TA的每日心情
    无聊
    2020-1-7 00:22
  • 签到天数: 270 天

    [LV.8]以坛为家I

    发表于 2018-11-24 14:34:10 | 显示全部楼层 |阅读模式
    啥也不说,直接上源码,不加权限,多给回复,谢谢。! U  L* i# N1 A4 l

    0 w1 o& `4 D# I7 ]$ D* F5 _- k# a5 v1 @4 U! y

    0 ?( K$ ~* N( b5 ?- q
    ) r8 {+ w7 d0 Q  t3 M: Z# f$ k# [* I8 m. s0 B

    9 J* f2 N: @# M) M& _8 a, Z- ], S7 Q; N
    [ecode=4].版本 2$ n- V! A6 a0 W1 |- R
    .支持库 internet
    - ]0 F3 h6 }0 p7 j7 n.支持库 spec
    - _) A3 f' p8 R1 @8 ]
    : \& x0 [- v5 _( q: ^.程序集 窗口程序集_启动窗口
    1 l9 `* P7 o, `5 H" I.程序集变量 img_data_u, 字节集
    8 j3 l$ ~5 M4 Q: S5 V9 s& b- g7 B5 t% |# D4 R2 O
    .子程序 __启动窗口_创建完毕
    : f4 c8 m; l; T* ^# A  y# ?) U: b3 D% U; H; ~2 {: k
    img_data_u = HTTP读文件 (“http://p0.qhimgs4.com/t014b70aac7897c728b.jpg”)
    ' j" L& m2 k* V! C& ]8 W图片框1.图片 = img_data_u# \. f$ C8 G; J1 k

    * O# R5 z* n% t& t+ R* g% K.子程序 OCR_PIC_TEXT, 文本型
    2 s6 k& G1 C1 I0 ~) e.参数 img_data, 字节集
    + f" B1 }5 S1 ]9 @.参数 fram, 逻辑型, 可空, 图片坐标,默认为空,值为假不输出,为真时输出$ {  o6 x/ p3 z; I3 e8 \( i
    .局部变量 url, 文本型, i3 H8 ]: ?& c- n* |
    .局部变量 data, 字节集( H1 o0 E$ ^: ?; o+ ~. V
    .局部变量 res, 文本型2 c$ c2 ~9 h  Q' E9 @1 ~
    .局部变量 num, 整数型
    2 l. }1 m6 T& H4 s.局部变量 Json, 类_json
    0 E8 n3 `; l; `, q/ s7 X.局部变量 data1, 文本型
    3 }; r8 E& K+ ]* B; h- y.局部变量 data2, 文本型% O$ Y) F6 _" n8 F
    .局部变量 res_data, 文本型0 Z  [1 u5 O) g
    7 S: N8 A) b) U. z/ V/ x; W: c
    url = “http://ocr.shouji.sogou.com/v2/ocr/json9 g9 D+ m" t: A& T. m0 l. o, \
    data = 到字节集 (#post_DATA)3 @7 X# t  r, Z0 Z, u, o
    data = 子字节集替换 (data, 到字节集 (“{IMG_DATA}”), img_data, , )
    4 g+ b/ J6 O* fres = 到文本 (网页_访问 (url, 1, , , , #HEADER, , , data))4 ^* D  ^- c8 S/ Y) O, x) X9 X8 _
    res = 编码_utf8到gb2312 (res)
    * {4 o7 v3 s# x+ z.if (json.解析 (res))
    ; i8 \" m# f7 i/ f- M) Y- o5 h* H    .counter (json.成员数 (“result”), num)
    ( \4 Q0 K; K- W( B# |7 w1 g        .ife (是否为空 (fram) 或 fram = 假)
    % h& z; z9 R: S2 @* c# Q            data2 = “”/ d5 L( \# P: G& O1 ]
            .否则! G% d6 k6 E* Y) F$ \. W; R! I
                data2 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].frame”)! D+ H. R1 a# j/ ?* m, Z/ V9 n8 |
            .如果结束# H2 J- f/ Z9 R3 i
            data1 = json.取通用属性 (“result[” + 到文本 (num - 1) + “].content”)
    ( w  O6 P, ~5 b! j# F        .ife (data2 = “”)
    - q7 {( `6 m, i: y# \+ {            res_data = res_data + data1 + #换行符6 W$ e  {8 J( c
            .否则
    - D- B& k+ Q$ S# [            res_data = res_data + data1 + #换行符 + data2 + #换行符& v. W9 h0 J' {* _6 e
            .如果结束1 S, O/ A+ O5 e' h0 a% v
    1 j6 K; L" w: Y3 U
        .CounterLoop ()! _' H& Z+ B% H* W
    .如果真结束
    + N  S, y8 h5 @; j+ ~+ yreturn (res_data)3 Y0 m3 n+ x0 ?; @

    : d4 |" c& ^/ W. L/ j4 x1 V
    - D5 [5 r  y# w.子程序 _按钮1_被单击
    8 p4 |8 ?! B7 Y$ N3 b" e
    8 [/ k5 Y2 M" r! p8 s% s, W9 Y调试输出 (OCR_PIC_TEXT (img_data_u))
    2 T0 S7 Z4 Z2 n8 N5 p7 u& _2 x1 Y% @# n% M
    6 ]7 _9 t& j" r9 ^
    .版本 2* E; L* }/ D  a4 ?3 y9 F! l
    # ^$ I/ E3 `. v  Y/ h- C
    .常量 头, "<文本长度: 129>"9 q1 E% q9 f: [. c* j/ E8 N- ]
    .常量 常量2
    & G  f5 y, O( E+ [4 O. ].常量 POST_DATA, "<文本长度: 209>"
    0 h, |) C5 h9 a, {.常量 前面, "<文本长度: 11>"3 Z. g1 M" [7 R7 w% K& i" P
    .常量 后面, "<文本长度: 8>"
    6 O: B# @/ D- c0 k; Q$ {$ X.常量 HEADER, "<文本长度: 79>"  z5 y  P  v* |+ H+ h+ y
    : p9 P' L  V0 _/ H- D* t

    # @5 S. U7 M' a# P3 A8 T[/ecode]
    3 V  L2 L  H" m6 d& |/ o9 `
    ' a+ q, d( B( H9 e) P- U4 Y

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    前天 09:35
  • 签到天数: 798 天

    [LV.10]以坛为家III

    发表于 2018-11-24 15:42:38 | 显示全部楼层
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    无聊
    2020-1-7 00:22
  • 签到天数: 270 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-24 15:43:10 | 显示全部楼层
    7 ]6 ]+ F4 B/ w) ]: x" n, s# p/ }
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-10-3 19:36
  • 签到天数: 13 天

    [LV.3]偶尔看看II

    发表于 2018-11-25 14:38:38 | 显示全部楼层
    用搜狗的接口都不用给钱了,哈哈
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2018-12-9 07:16
  • 签到天数: 10 天

    [LV.3]偶尔看看II

    发表于 2018-11-26 11:54:33 | 显示全部楼层
    验证码能识别?

    点评

    你可以试试。具体不晓得。  详情 回复 发表于 2018-11-26 11:55
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    2020-1-7 00:22
  • 签到天数: 270 天

    [LV.8]以坛为家I

     楼主| 发表于 2018-11-26 11:55:49 | 显示全部楼层
    1301ok 发表于 2018-11-26 11:54+ b$ @6 x0 m  R/ a9 V9 T
    验证码能识别?
    . a/ r7 _$ n1 A% C1 B4 {/ u. z' H
    你可以试试。具体不晓得。
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2019-1-25 14:32:26 | 显示全部楼层
    小姐姐,好像要
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-1-17 21:28 , Processed in 0.159320 second(s), 96 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表