易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费
验证码识别/打码平台/谷歌人机验证/
阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费各类验证码定制,注册赠送¥588礼包,点击领取阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费接码打码最高2000云产品通用代金券我要租广告
查看: 3186|回复: 1
收起左侧

[已解决] 易语言 程序_延时 求助

[复制链接]
  • TA的每日心情
    奋斗
    2019-7-29 19:26
  • 签到天数: 38 天

    [LV.5]常住居民I

    发表于 2019-6-22 17:53:35 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    程序_延迟的作用是什么 它和延迟的区别是什么?
    求dalao解答
    为什么下面代码必须调用 程序_延时 而且不能用延迟代替


    [C++] 纯文本查看 复制代码
    .版本 2
    
    .子程序 _按钮1_被单击
    .局部变量 进程句柄, 整数型
    
    .判断循环首 (真)
        .如果真 (进程是否存在 (“hl2.exe”) = 假)
            _启动窗口.可视 = 假
            信息框 (“未启动游戏!”, #信息图标, “小丑必须死提示:”, )
            销毁 ()
        .如果真结束
    
        进程PID = 取进程ID (“hl2.exe”)
        窗口句柄 = 取句柄 (“hl2.exe”)
        进程句柄 = 进程_打开 (进程PID)
        服务器类 = 取模块句柄ex (进程PID, “server.dll”)
        ' <===============本人=====================>
        本人基地址 = 读内存整数型 (进程PID, 服务器类 + 十六到十 (“4F2FEC”))
        本人坐标.x = 读内存小数型 (进程PID, 本人基地址 + 648 - 8)
        本人坐标.y = 读内存小数型 (进程PID, 本人基地址 + 648 - 4)
        本人坐标.z = 读内存小数型 (进程PID, 本人基地址 + 648)
        ' <===============本人=====================>
    
    
        ' <===============敌人一号=====================>
        敌人基地址 = 读内存整数型 (进程PID, 服务器类 + 十六到十 (“4F2FFC”))
        敌人坐标.x = 读内存小数型 (进程PID, 敌人基地址 + 784 - 8)
        敌人坐标.y = 读内存小数型 (进程PID, 敌人基地址 + 784 - 4)
        敌人坐标.z = 读内存小数型 (进程PID, 敌人基地址 + 784)
    
        ' <===============敌人一号=====================>
    
        ' <===============敌人二号=====================>
        敌人基地址2 = 读内存整数型 (进程PID, 服务器类 + 十六到十 (“4F300C”))
        敌人坐标2.x = 读内存小数型 (进程PID, 敌人基地址2 + 784 - 8)
        敌人坐标2.y = 读内存小数型 (进程PID, 敌人基地址2 + 784 - 4)
        敌人坐标2.z = 读内存小数型 (进程PID, 敌人基地址2 + 784)
        ' <===============敌人二号=====================>
    
    
        编辑框1.内容 = 到文本 (本人坐标.x)
        编辑框2.内容 = 到文本 (本人坐标.y)
        编辑框3.内容 = 到文本 (本人坐标.z)
    
        编辑框6.内容 = 到文本 (敌人坐标.x)
        编辑框5.内容 = 到文本 (敌人坐标.y)
        编辑框4.内容 = 到文本 (敌人坐标.z)
    
        编辑框9.内容 = 到文本 (敌人坐标2.x)
        编辑框8.内容 = 到文本 (敌人坐标2.y)
        编辑框7.内容 = 到文本 (敌人坐标2.z)
    
       程序_延时 (200, )
    .判断循环尾 ()




    揰掵佲已获得悬赏 1 助乐+100 易币

    最佳答案

    说到延迟,必须说一下延时! 延时:系统核心支持库->系统处理 这个玩意,用的人很少,原因很简单,这是暂停当前程序!短暂的卡死!不让你进行任何操作。 延迟: 特殊功能支持库->系统处理 这个相对的来说, ...
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    1 小时前
  • 签到天数: 747 天

    [LV.9]以坛为家II

    发表于 2019-6-22 19:39:01 | 显示全部楼层
    说到延迟,必须说一下延时!

    延时:系统核心支持库->系统处理  这个玩意,用的人很少,原因很简单,这是暂停当前程序!短暂的卡死!不让你进行任何操作。
    延迟: 特殊功能支持库->系统处理 这个相对的来说,多一些,但是毕竟不是核心库,延迟一段时间,然后继续执行后面的程序代码。与易语言核心支持库中的“延时()”命令不同的是,本命令在等待期间允许用户进行其它操作(如点击按钮等)
    程序_延时:说白了就是API重写的  SetWaitableTimer 主要是这个函数
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2019-11-13 05:36 , Processed in 0.095567 second(s), 85 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表