易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第6期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
查看: 681|回复: 2
收起左侧

[易求助] 易语言大漠插件的问题

[复制链接]
  • TA的每日心情
    奋斗
    2020-5-11 15:59
  • 签到天数: 4 天

    [LV.2]偶尔看看I

    发表于 2020-5-6 22:27:18 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    我这段代码里面的移动命令为什么不好使啊?之前有人帮忙看了下,直接一下就调试好了,应该是顺序那块出了问题,后来我怎么弄也不行了,就是那块移动不好使,里面的属性是对的,我又写了一个命令,直接打开就可以运行移动命令,我也发在帖子里面下,那位老师帮忙看下,是因为什么原因,谢谢了啊。

    66666666.jpg


    .版本 2

    i = 1
    启动状态 = “打开游戏”


    .判断循环首 (i > 0)
        .判断开始 (启动状态 = “打开游戏”)
            是否成功 = xx.RunApp (编辑框_游戏路径.内容, 0)
            .如果 (是否成功 = 1)
                ' 这就是成功了
                列表框内容 (“启动游戏成功”)
                i = 1
                启动状态 = “游戏是否打开”
            .否则
                i = i + 1
                列表框内容 (“启动游戏失败”)
                .如果真 (i > 3)
                    ' "停止脚本"
                .如果真结束

                xx.delay (5000)
            .如果结束

        .判断 (启动状态 = “游戏是否打开”)
            句柄 = xx.FindWindow (“GLFW30”, “神武4 ”)
            xx.delay (1000)
            .如果 (句柄 = 0)
                列表框内容 (“没有找到游戏窗口”)
                i = 1 + 1
                xx.delay (2000)
                .如果真 (i > 3)
                    启动状态 = “打开游戏”
                    到循环尾 ()
                .如果真结束


            .否则
                ' 这里是找到了
                列表框内容 (“找到了游戏窗口”)
                xx.delay (1000)
                xx.MoveWindow (句柄, 0, 0)
                xx.delay (3000)

            .如果结束
            启动状态 = “是否达到输入账号界面”

        .判断 (启动状态 = “是否达到输入账号界面”)
            图片 = xx.FindPic (555, 67, 871, 528, “开始游戏.bmp”, “000000”, 0.9, 0, inX, inY)
            .如果 (图片 ≠ -1)
                列表框内容 (“找到了游戏图片了”)
                xx.MoveTo (inX + 5, inY + 3)
                xx.delay (600)
                xx.LeftClick ()
                xx.delay (2000)

            .否则
                xx.delay (1000)
            .如果结束

            图片 = xx.FindPic (205, 250, 629, 465, “游戏界面.bmp”, “000000”, 0.9, 0, inX, inY)
            .如果 (图片 ≠ -1)
                列表框内容 (“成功进入游戏界面”)
                列表框内容 (“请输入账号和密码”)
            .否则
                xx.delay (1000)
            .如果结束

        .默认


        .判断结束


    第二个代码

    .版本 2

    xx.RunApp (编辑框_游戏路径.内容, 0)
    xx.delay (5000)
    句柄 = xx.FindWindow (“GLFW30”, “神武4”)
    xx.MoveWindow (句柄, 0, 0)





    我知道答案 回答被采纳将会获得1 助乐 + 10 易币 已有2人回答
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    2020-5-11 15:59
  • 签到天数: 4 天

    [LV.2]偶尔看看I

     楼主| 发表于 2020-5-6 23:23:04 | 显示全部楼层
    这个是源码  链接: https://pan.baidu.com/s/1NWyZlSmbftH4W5EmTMEn8A 提取码: 4uc4 复制这段内容后打开百度网盘手机App,操作更方便哦
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    郁闷
    昨天 01:54
  • 签到天数: 931 天

    [LV.10]以坛为家III

    发表于 2020-5-7 08:16:49 | 显示全部楼层
    大漠之类的,排错最简单的妨碍
    1.确定是否找到对应界面(可以输出内容或者下断)
    2.延迟是否够了
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-6-7 03:36 , Processed in 0.055996 second(s), 101 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表